Sharepoint 2010: Error While Deploying Custom List Instance Feature


Error:

Error occurred in deployment step ‘Activate Features’: Feature ’00bfea71-d1ce-42de-9c63-a44004ce0105′ for list template ‘100’ is not installed in this farm. The operation could not be completed.

ULS:

Failed to find the list schema for FeatureId ’00BFEA71-D1CE-42de-9C63-A44004CE0105′, list template ID 100. Cannot create list in web “http://” at URL “Lists/”.

<nativehr>0x8107058a</nativehr><nativestack></nativestack>Feature ’00bfea71-d1ce-42de-9c63-a44004ce0105′ for list template ‘100’ is not installed in this farm. The operation could not be completed.

Solution:

Replace your FeatureID in Elements.xml with:

00BFEA71-DE22-43B2-A848-C05709900100

Like this:

<Elements xmlns=”http://schemas.microsoft.com/sharepoint/”&gt;

    <ListInstance

        Title=”CustomList”

        Description=”Desc”

        FeatureId=”00BFEA71-DE22-43B2-A848-C05709900100″

        Id=”B3738CB0-EFE0-4B20-BF50-5D42E637D4EF”

        Url=”Lists/CustomList”

        OnQuickLaunch=”TRUE”

Advertisements

One thought on “Sharepoint 2010: Error While Deploying Custom List Instance Feature

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s